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If you're typing in data that has a pattern to it, Excel can
complete the pattern for you. You can use this for number
sequences, times, and dates.
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Enter the start of the sequence into two cells. If it's
a number sequence, you'll need to enter at least
two numbers. For times and dates, Excel can use
just one. For alternate months (January, March,
etc.), you'd enter the first two to show the pattern.

Highlight the cells containing your data.

Click the Fill handle. It's a tiny

dot in the bottom right of 1
the selected area. Your cursor 3
becomes a small black cross 5
when you hover over it. @
=

Drag the mouse to cover

the area you want to fill. In

the example shown here, you'd drag down. As
you drag, you'll see the value that's being added
shown next to your cursor.

Click the Auto Fill Options menu that appears
beside your cursor to find options for the fill,
including Copy, which fills each cell with the data
you've selected. You can also fill weekdays, days,
months, or years from dates. Try putting 31-Jan

in the first box, then autofilling months to get the
last day of each month.

Even quicker: If you just want a sequence of
numbers going up by 1, enter the first number,
select the cell and hold down Ctrl while you drag
the Fill handle.
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There's an even quicker way to autofill a range so it matches
the size of the neighboring columns.
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Enter the first two data items in the sequence you
want to use. For example, if you want to add years
starting at 2025 and want to increase by 1 each
time, enter 2025 and 2026 into two cells.

Highlight both cells containing the data items you
just entered.

Period USsales UKsales
2025 65 1
2026 72 22

@ 46 232

98 12

23 54

45

54

Double-click the Fill handle in the bottom right of
the selected area.

Your data column is

automatically filled Period USsales UKsales
. 2025 65 11
to match the size T oo 7 2
of the neighboring | s 45 232
columns. In my 2028 98 12
example, the e 23 54
. 2030 a5
autofill extends to = =
where the data -

ends in the third
column, even
though the nearest
column is shorter.
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Introduced in Excel 2013, Flash Fill recognizes patterns

in data based on neighboring cells. It's much more
sophisticated than Auto Fill. You can use it, for example, to
reformat text and split or combine data. Here's an example.

a You might have a list of names, with the first name
and last name combined. For the first row, type the
first and second names into the next cells. This is
how you teach Excel the pattern to copy.

Name First Name Surname
Murphy Slaw  Murph Slaw
Bob Sled | .l

Phil Space

Dave Triffids

Gladys Working

e Position your cursor in the empty first name cell for
the second name.

e Press Ctrl 4+ E or click the Flash Fill button on
the ribbon. Find it by clicking the Data tab, then
looking in the Data Tools.

SHEl B = B~ =5 @

Textto Flash Remove Data  Consolidate Manage
Columns  Fill  Duplicates Validation ~ Data Model
Data Tools

o The first name column is then automatically filled
out for you. Check the results look okay, and then
do the same for the last name column.
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Here are some tips for adjusting the width of columns.
Similar ideas apply to rows.

o To adjust the width of a column, click and drag

the line to the right of its letter above the column.
Here, I'm adjusting the width of column C.

A B |0 €« D E F

To make the column width snap to the width of
the content in the column, double-click this same
dividing line above the column, on its right.

You can select several columns and adjust them

at the same time, making them equal width, or
making them all snap to their content width. To
select a column, click its letter. Click and drag on
the letters to select multiple columns, or use Ctrl +
click to select columns that aren’t adjacent.

You might want to set the column width to a
particular cell in the column, rather than the widest
cell. Perhaps one cell contains a title that you're
happy to run into other cells. Select the cell you
want to adjust the width to, go to Format in the
Cells group of the Home tab, and select AutoFit
Column Width.

This is a long title, which we don’t want to fit the column to
Books

Stationery

Frozen produce

Recorded media



C

I'll show you how to quickly insert multiple rows. You can
use a similar technique to insert columns.

Click the number of the row where you want to
insert above, and drag down for as many rows as
you want to insert. For the example here, | want to
insert three rows above row 4.

Ho v b wn -

B C D E F G H
Jan Feb Mar Apr May Jun
Tractors 247 750 500 145 165 400
Diggers 325 155 600 655 750 530]
Dump trucks 125 300 932 800 600 400

Click Insert in the Cells group of the Home tab. You
could alternatively use Ctrl with the plus symbol
(4). You can use the + key on your number
keypad or add Shift to the key combination to use
the key on the main keyboard.

DN O L AW N -

o

B C D E F G H
Jan Feb Mar Apr May Jun
Tractors 247 750 500 145 165 400
~ Diggers 325 155 600 655 750 530
Dump trucks 125 300 932 800 600 400

If you're inserting a row to copy another row into
it, you can save time by copying the row first.
When you insert, your copied row will be pasted
into the new row(s).
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There are several techniques that can help you to manage
large spreadsheets.

On the View tab, click New Window to see

your worksheet in another window at the same
time. You can scroll around in the windows
independently, but it's just two views of the same
document. Any changes you make will be visible in
both windows. Use Arrange All on the View tab to
organize your windows side by side.

Keep column and/ Elveningon S 0 = | [

H BaArangeall  [AHide (] (‘)_ =)
or row headings z & Switch | Macrs
. . hen B Freeze Panes~ [ ) Windows v -
in view w —

4oy Erecze Panes
you scroll. Also D fnemtcion Skl
i F Top Row
on the View tab’ - ’E@ K::xt:e::pwwvisiblewhilescmllingthwugh
Freeze Panes can E—
reeze First Column

keep the top row % Keep the first column visible while scrolling

through the rest of the worksheet.

or first column

in view. You can

freeze both by selecting the cell that is underneath
the column heading and to the right of the row
heading that you want to keep, and then choosing
Freeze Panes. Using this approach, you can freeze
several rows or columns.

Focus on what's —
importa nt by Hide Rows Hide & Unhide >
h|d|ng rows and Hide Columns Organize Sheets
columns you don't i hedt BB Benome sheet

. Unhide Rows Move or Copy Sheet...
need right now. I = ,

Select the rows or Protection

columns (click and

drag on their letters or numbers in the margin),
and choose Hide Rows or Hide Columns. These
options are on the Home tab, in the Editing group,
under the Format menu.
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To improve data quality, you can validate data as it is
entered into the spreadsheet.

o Select the cells you want to apply validation to.

e Click Data Validation on the Data tab of the
ribbon. The Data Validation options open.

9 In the Allow menu, you can choose to allow any
value (the default), whole numbers, decimals,
dates, times, or text of a certain length. You can
also define custom validation (see Tip 9) or use a
list of valid data items (see Tip 8).

0 In the Data menu, you can choose a sequence
of valid values (between), minimum and/or
maximum values, or a sequence of invalid values
(not between). Use the boxes below to enter the
start and end dates, or minimum and maximum
numbers. Use the Input Message tab to give users
instructions on entering valid data. Instructions are
shown when users select the cell.

Data Validation » Bl

Settings | Input Message l Error Alert

Validation criteria
Allow:
| Date | V1 Ignore blank
Data:

between Iv|

Start date:

01/01/1300 [2]
End date:

31/12/1999 [2]

[] Apply these changes to all other cells with the same settings

Clear All Cancel
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You can ensure data is valid and speed up its entry by
putting a drop-down menu in a cell. This is one of the data
validation options.

o Select the cell(s) where you want to use the menu.

e Click Data Validation on the Data tab of the ribbon
to open the Data Validation options. There's a
shortcut: press ALT, D, and L one at a time.

e In the Allow Dot vatcation * I
d ro p_d own Settings | Input Message | Error Alert
menu, Validation criteria
. Allow:
choose List. —— v @ anore in
Data: In-cell dropdown
between v]
Source:
o In the Small, Medium, Large, X-Large, XX-Large| (2]
Source box,
type th e Apply these changes to all other cells with the same settings
menu items, Geacha e
separated by
a comma.
Click OK.

e If you prefer, you can use data that's in a
spreadsheet row, column, or named range (see
p.41). In that case, enter an = sign followed by
the name in the Source box, or enter = there and
then select the menu items on the spreadsheet
using the mouse. It's easy to edit your menu later
by simply editing those cells.

0 When you select one of
the cells, a menu wiill
appear so you can select
the data you'd like to
enter in that cell.
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You can write your own validation rules. Select the cell(s)
you want to validate and go to the Data Validation options
(see Tip 7). Select Custom in the Allow menu. In the Formula
box, enter a formula that gives a result of TRUE or FALSE.
Here are some examples to validate cell J8:

® Must start with text “CPC"”. =COUNTIF(J8, “"CPC*")=1
® Length must be 3. =LEN(J8)=3
® Must be a number. =ISNUMBER(J8)

® First character must be a number. The LEFT function
is used to extract the character, and ISNUMBER is
used to test whether it is a number. The VALUE
function is required because in a data item like
"UK-52", the 52 would otherwise be treated as text.
=ISNUMBER(VALUE(LEFT(8,1)))

® Last character must not be a number. To see whether
a character is not a number, we can check whether it
is a number, and then wrap it in the NOT function to
reverse the result.
=NOT(ISNUMBER(VALUE(RIGHT(I8,1))))

® Must be unique in column J. This shows an error if
the same data has already been entered in the same
column. =COUNTIF(J:J, J8)< =1

® Must be odd. =ISODD(8). ISEVEN can be used, too.

To allow multiple options, join them with OR, like this
example, which allows data of 3 or 5 characters to be valid:

=O0R(LEN(J8)=3, LEN(J8)=5)

To enforce multiple validation rules, use AND, like this
example, which requires a 3-character code starting with A:

=AND(LEN(J8)=3, COUNTIF(I8, "A*")=1)
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You can remove duplicated data in a spreadsheet, which
can easily happen if data such as mailing list information is
combined from multiple sources.

Click in your data so Excel can find it.

Click Remove Duplicates on the Data tab of the
ribbon. You'll find it in the Data Tools group.

Select the columns that you want to check for
duplicate entries. It's safest to keep them all
selected. If you just selected the First Name and
Last Name (for example), two different people who
share a name would be identified as duplicates,
even though they have different addresses. One of
them would be automatically deleted. This doesn’t
happen if you select the address fields as well.

Remove Duplicates i < |

To delete duplicate values, select one or more columns that contain duplicates.

My data has headers

Columns A
First Name

Last Name

Street

City

Postcode

[Vl _Countrv b

oK Cancel

Click OK. Beware, though, as that might
delete rows from your spreadsheet. Use Undo
immediately to bring them back if you made a
mistake.



Boost your productivity with Excel:

Discover useful timesaving features
Master data entry shortcuts
Use powerful functions for processing data
Create pivot tables for insightful data analysis
Get clever with What-if and Goal-seek
Use graphs & charts to see the whole picture
Learn to debug formulas to find errors
Work with large spreadsheets
Whether you've been using Excel for years and never
gone beyond the basics, or are just entering the world
of spreadsheets, this book will quickly supercharge your
Excel skills. Save hours by using the quick tips for data

entry, and get more out of Excel by exploring the powerful
tools on offer for data analysis — all in easy steps!
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